$re = '/^(?:http(?:s)?:\/\/)?(?:www)?/m';
$str = 'example.com
http://example.com
http://www.example.com
website.com';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);