const regex = /\\(.*\s\b[^\\]+?)\\/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\\\(.*\\s\\b[^\\\\]+?)\\\\', 'g')
const str = `cat "food" | c:\\Program Files\\nodejs\\node.exe
c:\\Program Files\\nodejs\\node.exe
cat "c:\\Program Files\\nodejs\\node.exe" | pipe | c:\\apps and stuff\\node.exe`;
const subst = `\\"$1"\\`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);