const regex = /\<h1(.*(class="(?P<class>.+)"?).*|)\>(?P<text>[^\<]+)\<\/h1\>/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\<h1(.*(class="(?P<class>.+)"?).*|)\\>(?P<text>[^\\<]+)\\<\\\/h1\\>', 'g')
const str = `<h1
class="sdkfjh">fhgkfg</h1>
<h1 class='sdkfjh'>askjdhsdkj</h1>
<h1
style="gjh" class="sdkfjh">askjdhsdkj</h1>`;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}