re = /\<h1(.*(class="(?P<class>.+)"?).*|)\>(?P<text>[^\<]+)\<\/h1\>/
str = '<h1
class="sdkfjh">fhgkfg</h1>
<h1 class=\'sdkfjh\'>askjdhsdkj</h1>
<h1
style="gjh" class="sdkfjh">askjdhsdkj</h1>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end