#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:^I have:?|\G(?!^)(?: and)?) an? ((?:(?! and | an? ).)+)"
Local $sString = "I have an eraser and a pencil" & @CRLF & _
"She has a turtle and a car" & @CRLF & _
"I have an awesome motorcycle a helmet and a bag" & @CRLF & _
"I have a journal"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")