using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:^I have:?|\G(?!^)(?: and)?) an? ((?:(?! and | an? ).)+)";
string input = @"I have an eraser and a pencil
She has a turtle and a car
I have an awesome motorcycle a helmet and a bag
I have a journal";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}