import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:^I have:?|\\G(?!^)(?: and)?) an? ((?:(?! and | an? ).)+)";
final String string = "I have an eraser and a pencil\n"
+ "She has a turtle and a car\n"
+ "I have an awesome motorcycle a helmet and a bag\n"
+ "I have a journal";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}