const regex = /(?:^I have:?|\G(?!^)(?: and)?) an? ((?:(?! and | an? ).)+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:^I have:?|\\G(?!^)(?: and)?) an? ((?:(?! and | an? ).)+)', 'gm')
const str = `I have an eraser and a pencil
She has a turtle and a car
I have an awesome motorcycle a helmet and a bag
I have a journal`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}