$re = '/(?:^I have:?|\G(?!^)(?: and)?) an? ((?:(?! and | an? ).)+)/m';
$str = 'I have an eraser and a pencil
She has a turtle and a car
I have an awesome motorcycle a helmet and a bag
I have a journal';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);