use strict;
my $str = 'I have an eraser and a pencil
She has a turtle and a car
I have an awesome motorcycle a helmet and a bag
I have a journal';
my $regex = qr/(?:^I have:?|\G(?!^)(?: and)?) an? ((?:(?! and | an? ).)+)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}