re = /(?:^I have:?|\G(?!^)(?: and)?) an? ((?:(?! and | an? ).)+)/m
str = 'I have an eraser and a pencil
She has a turtle and a car
I have an awesome motorcycle a helmet and a bag
I have a journal'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end